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Abstract:

Crimson® provides advanced Ethernet communication capabilities for Red Lion Controls CR1000 
Human Machine Interface (HMI), CR3000 HMI, Data Station Plus (DSP) (excludes LE), G3 HMI, 

G3 Kadet HMI, Graphite® Controller, Graphite HMI, Modular Controller (excludes LE), and 
ProducTVity Station™ (PTV) products. When used with the Siemens S7-300 Ethernet driver, 
Crimson enables users to exchange Programmable Logic Controller (PLC) data with Red Lion 
devices via industrial Ethernet networks. 

Products:

CR1000 HMI, CR3000 HMI, DSP (excludes LE), G3 HMI, G3 Kadet HMI, Graphite Controller, 
Graphite HMI, Modular Controller (excludes LE) and PTV

Use Case:

This document describes how to set up communication between a G3 HMI and an S7-300 PLC 
using Ethernet and Siemens ISO Protocol. Setting up communication between an S7-300 PLC and 
the previously identified Red Lion devices using Ethernet and Siemens ISO Protocol is similar.

Required Software: 

Crimson 3.1, Crimson, 3.0, or Crimson 2.0

Required Operating System:

Microsoft Windows 2000, or above
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Introduction

The following steps describe how to set up communication between a G3 HMI and an S7-300 PLC using Ethernet 
and Siemens ISO Protocol. This document can also be used as a reference to set up Red Lion CR1000 HMI, 
CR3000 HMI, DSP (excludes LE), G3 Kadet HMI, Graphite Controller, Graphite HMI, Modular Controller (excludes 
LE) and PTV products.Three major types of connections are available:

1. Setup 1 - Communication with an S7-300 PLC with built in Ethernet port and supporting Siemens ISO        
protocol

2. Setup 2 - Communication via optional Ethernet card for S7-300 series, type CP343-1; supports TSAP con-
nections (e.g. CP343-1 Advanced IT)

3. Setup 3 - Communication via optional Ethernet card for S7-300 series, type CP343-1; does not support 
TSAP connection (e.g. CP343-1 Lean).

Each connection type is presented in this document. A given application should follow only one of the three previ-
ously defined setups. The Ethernet driver has been tested and validated with the following products:

•CPU315-DP/PN – P# 6ES7 315-2EG10-0AB0, v2.3

•CP343-1 – P# 6GK7 343-1EX20-0XE0, v1.1

•CP343-1 Advanced IT – P# 6GK7 343-1GX21-0XE0, v1.0

•CP343-1 Lean – P# 6GK7 343-1CX00-0XE0, v1.0

NOTE: These features only work with Crimson 2.0 or above and are only available to Windows 
2000 or above users. Please update your version of Crimson to the latest; available online 
at www.redlion.net
2 Communication with Siemens S7-300 PLCs via Ethernet

 



Communication with Siemens S7-300 PLCs via Ethernet TNOI34 Rev B
Setup 1 – S7‐300 CPU With Built‐In Ethernet Port

Setting Up The PLC For CPU Communication

The PLC must be set up before communication can begin, because G3 HMI communication settings are 
determined by how the PLC is configured. 

1. Start SIMATIC Manager and follow the wizard to create a new project. In this example, a CPU315-2 PN/DP is 
used. Once created, the project browser should look similar to Figure 1.

2. Select SIMATIC 300 from the tree in the left -hand pane and then double click the Hardware symbol in the 
right-hand pane to access the HW Config screen (Figure 2).

Figure 1.  
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3. Double click PN-IO to access the Ethernet port configuration, as shown in Figure. 2. Note the CPU rack num-
ber and slot position, here respectively 0 and 2, as they will be important later when setting up Crimson.

4. In the General tab, click on Properties; this opens the two popup windows (Figure 3) used to set up the Ether-
net network. 

Figure 2.  

Referring to Figure 3:

1. From the Parameters tab, enter the IP address for the PLC; 192.168.200.20 is used in this example.

2. Click the New button to create a new Ethernet network.

3. Click the OK button.

Figure 3.  
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4. Make sure the Ethernet network just created (Ethernet 1 in Figure 3) is selected. This identifies the Network 
to which the CPU will be connected and activates the Ethernet port (Figure 4).

Figure 4.  

5. Click OK to close all popup windows and return to HW Config. Save the configuration and close HW Config. 
The PLC configuration is done; settings can now be downloaded to the PLC.
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Setting Up The G3 HMI For CPU Communication

Once the PLC has been set up, all required information is available to configure the G3 HMI. Start Crimson and 
create a new database (File>New). Select the device to be programmed. In this example, we are programming a 
G306 HMI.

Enter the “Communications” module and follow the steps shown in Figure 5:

1. Select the Ethernet port.

2. Define the Port Mode. In this example, Manual Configuration is selected.

3. Enter the G3 HMI IP address, if required; 192.168.200.10 is used in this example.

Figure 5.  
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Once the Ethernet port is activated, the communication driver must be defined, as shown in Figure 6:

1. Select Protocol 1 under Ethernet.

2. On the right-hand pane, specify the driver and click Pick to select that driver.

3. In the popup window, under Manufacturer, select Siemens.

4. Under Driver, select S7 300 TCP/IP Master and click OK.

A device named PLC1 should appear under Protocol 1. This device represents the Siemens S7-300 PLC and can 
be renamed as required to fit each application.

Figure 6.  

In this example, the device will be renamed S7300. Right-clicking the PLC and selecting “Rename” facilitates 
renaming the device.
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The device settings must now be set to fit the PLC configuration. Refer to Figure 7 and perform the following:

1. Select the device representing the PLC; PLC1 in this example.

2. Change the IP address to the PLC IP address; 192.168.200.20 in this example.

3. Select the Type as S7 300/400 CPU.

4. Enter the CPU rack number; 0 in this example.

5. Enter the CPU slot position on the rack; 2 in this example.

Figure 7.  
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The communications settings are now complete. Close the “Communications” module and enter the “Data Tags” 
module to map the variables to the PLC registers, as shown in Figure 8. For example, to map a Data Block, per-
form the following steps:

1. Create an integer variable.

2. Select the variable, click on Internal in the Data tab, and select the device (PLC1 in this example).

3. Select the Siemens data item to exchange, here DB.

4. Choose the data type (refer to following note on Data Type).

5. Select the starting element for the data item (identical to PLC addresses) and click OK.

Once the tags are inserted on the screen, the database is now ready and can be downloaded in the G3 HMI.

 

Figure 8.  

Note On Data Type:

Byte as Byte means the variable will contain a Byte, Byte as Word means the variable will contain 
an integer word, and Byte as Long means the variable will contain an integer long; the G3 HMI 
asks the PLC the number of bytes required to reconstruct the data type selected. 

For example, for a Byte as Word mapped at DB001:006, the G3 will ask for DB001:006 and 
DB001:007 and reverse the bytes to reconstruct the word automatically. The address given in the 
Element should be the same as the one defined in the PLC Data Block for this example.
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Set Up 2 – Communication Via CP343 Optional Ethernet Card Supporting TSAP 
Connections

Setting Up The PLC For CP343 Communication

The PLC must to be set up first, as G3 HMI communication settings are determined by how the PLC is configured.

1. Start SIMATIC Manager and follow the wizard to create a new project. This example uses a CPU315-2DP 
and a CP343-1. Once created, the project browser should look similar to Figure 9.

2. Select SIMATIC 300 from the tree in the left -hand pane and then double click the Hardware symbol in the 
right-hand pane to access the HW Config screen (Figure 10).

Figure 9.  
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3. Once in HW Config, browse the object library on the right-hand pane to find the optional Ethernet card 
CP343-1. Drag and drop the card to an available slot, as shown in Figure 10.

Figure 10.  

As the object is dropped on a slot, a pop up appears for configuring the Ethernet configuration, as shown in Figure 
11. Referring to Figure 11: 

1. Enter the IP address for the PLC; 192.168.200.20 in this example.

2. Click New to create a new Ethernet network.

3. Click OK.
Communication with Siemens S7-300 PLCs via Ethernet 11

 



Communication with Siemens S7-300 PLCs via Ethernet TNOI34 Rev B
Figure 11.  

4. Make sure the Ethernet network just created is selected. This identifies the network the CP343 will be con-
nected to and activates the Ethernet port (Figure 12).

 

Figure 12.  

5. Click OK to close all popup windows and return to HW Config. Save the configuration and close HW Config. 
The project manager should now display the CP343-1 communication card in the tree, as shown in Figure 13.
12 Communication with Siemens S7-300 PLCs via Ethernet

 



Communication with Siemens S7-300 PLCs via Ethernet TNOI34 Rev B
Now a connection between the PLC and the G3 HMI must be created. This connection is set up using Net Pro. 
Select PLC CPU and double click on the Connections icon to access the NetPro configuration tool, as shown in 
Figure 13. 

Figure 13.  
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Once in NetPro, refer to Figure 14 and perform the following steps:

1. Select the CPU.

2. Double click on the first line in the table.

3. The Insert New Connection pop-up appears.

4. Go to the Station field and ensure Unspecified is selected.

5. Make sure that the Connection Type is S7 Connection.

6. Click the OK button; the Properties - S7 Connection window (Figure 15) appears.

Figure 14.  
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Enter the following information, as shown in Figure 15:

1. Make sure “Establish an active connection” is NOT checked; this makes the PLC the Server.

2. Make sure the Interface selected is CP 343-1 (R0/S4).

3. Enter the Partner name (any name works); G306 is used in this example. The partner is the device with which 
the S7 will create a connection.

4. Enter the Partner IP address; 192.168.200.10 in this example. Then, click on Address Details, which 
launches the Properties - S7 Connection pop-up window (Figure 16).

Figure 15.  
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This popup window is important as it contains communication information required to setup the G306 in Crimson. 
Referring to Figure 16, perform the following steps:

1. PLC Connection Resource

2. PLC TSAP information. The first part of the number, before the decimal point, represents the Server Connec-
tion Resource; the second part is the rack slot number where the CP343 is installed. In this example, the Con-
nection Resource is 10 and the slot 04.

3. Partner Rack/Slot, they should stay at zero.

4. Partner Connection Resource, this number can be different from the PLC Connection Resource.

Figure 16.  

Click OK to close all popup windows and return to NetPro. The table now shows the connection just created on the 
first line. Save and compile in NetPro and close this window to go back to the project manager.

The PLC is now configured. Download the configuration and make sure the PLC accepts the entire configuration, 
especially the connection settings. We recommend using the command “PLC > Compile and Download Objects…”
16 Communication with Siemens S7-300 PLCs via Ethernet
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Setting Up The G3 HMI For CP343 Communication Using TSAP Connections

Once PLC setup is complete, all required information is available to configure the G3 HMI. Start Crimson software 
and create a new database (via File>New). Select the device to be programmed. In this example, a G306 HMI is 
used.

Enter the “Communications” module and follow the steps shown in Figure 17:

1. Select the Ethernet port.

2. Define the Port Mode. In this example, Manual Configuration is used.

3. Enter the G3 IP address if required; 192.168.200.10 is used in this example.

Figure 17.  
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Once the Ethernet port is activated, the communication driver must be defined, as shown in Figure 18:

1. From the Navigation Pane, under Network, select Protocol 1.

2. On the right-hand pane, specify the driver and click Pick to select that driver.

3. In the popup window, under Manufacturer, select Siemens.

4. Then, under Driver, select S7 300 TCP/IP Master and click OK.

A device named PLC1 should appear under Protocol 1. This device represents the Siemens PLC and can be 
renamed as required to fit each application; S7300 is used in this example.

Figure 18.  
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The device settings now have to be set up to fit the PLC configuration, as shown in Figure 19.

1. Select the device representing the PLC.

2. Change the IP address to the PLC IP address; 192.168.200.20 in this example

3. Select the Type as CP 343.

4. Enter the Server connection in hexadecimal. This is the PLC Connection Resource defined in Simatic NetPro, 
as shown in Figure 16; 10 in this example.

5. Enter the Client connection in hexadecimal. This is the G3 Connection Resource defined in Simatic NetPro, 
as shown in Figure 16; 03 in this example.

6. Enter the CP343 Slot position in the rack, as previously specified in Figure 16; 04 in this example.

Figure 19.  
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The communications settings are now complete. Close the “Communications” module and enter the “Data Tags” 
module to map variables to PLC registers, as shown in Figure 20. For example, to map a Data Block, perform the 
following steps:

1. Create an integer variable.

2. Select the variable, click on Internal in the Data tab and select the device (here S7 300).

3. Select the Siemens data item to exchange, here DB.

4. Choose the data type (refer to following note on Data Type).

5. Select the starting element for the data item (identical to PLC addresses) and click OK.

Once the tags are inserted on the screen, the database is now ready and can be downloaded to the G3 HMI.

Figure 20.  

Note On Data Type:

Byte as Byte means the variable will contain a Byte, Byte as Word means the variable will contain 
an integer word, and Byte as Long means the variable will contain an integer long; the G3 HMI 
asks the PLC the number of bytes required to reconstruct the data type selected. 

For example, for a Byte as Word mapped at DB001:006, the G3 will ask for DB001:006 and 
DB001:007 and reverse the bytes to reconstruct the word automatically. The address given in the 
Element should be the same as the one defined in the PLC Data Block for this example.
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Setup 3 – Communication Via CP343 Optional Ethernet Card NOT supporting 
TSAP Connections (Transparent Mode)

The following setup is required if you are using a CP343-1 Lean module.

Setting Up The PLC For CP343 Communication

Start SIMATIC Manager and follow the wizard to create a new project. This example uses a CPU315-2DP and a 
CP343-1 Lean. Once created, the project browser should look similar to Figure 21.

Figure 21.  

Select the SIMATIC 300 PLC in the tree and double click the Hardware symbol to access HW Config.
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Once in HW Config, browse the object library on the right hand pane to find the optional Ethernet card CP343-1 
Lean. Drag and drop the card to an available slot as shown in Figure 22.

 

Figure 22.  

When you drop the object on a slot, a window will pop up for the Ethernet configuration.
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Referring to Figure 23, perform the following:

1. Setup the IP address for the PLC, here 192.168.200.20.

2. Click new to create a new Ethernet network.

3. Click OK.

Figure 23.  

4. Make sure the Ethernet network just created is selected. This identifies the Network the CP343 will be con-
nected to and activates the Ethernet port (Figure 24). 

5. Click OK to close all popup windows and return to HW Config. Save the configuration and close HW Config. 
The PLC is now configured. Download the configuration and make sure the PLC takes the entire configura-
tion.

Figure 24.  
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Setting Up The G3 For CP343 Communication NOT Supporting TSAP Connections

Once the PLC has been configured, all required information is available to configure the G3 HMI. Start Crimson 
and create a new database (via File>New). Select the device to be programmed; a G306 HMI is used in this 
example.

Enter the “Communications” module and follow the steps as shown in Figure 25:

1. Select the Ethernet port.

2. Define the Port Mode. In this example, it will be Manual Configuration.

3. Enter the G3 IP address if required; 192.168.200.10 is used in this example.

Figure 25.  

1
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Once the Ethernet port is activated, the communication driver has to be defined as shown in Figure 26:

1. From the Navigation Pane, select Protocol 1 under Network.

2. On the right hand pane, specify the driver and click Pick to select that driver.

3. In the popup window, under Manufacturer, select Siemens.

4. Then, under Driver, select “S7 300 TCP/IP Master” and click OK.

A device called PLC1 should then appear under the Protocol 1 field. This device represents the Siemens PLC and 
can be renamed to fit your application.

Figure 26.  

In this example, the device will be renamed S7300. Right-clicking the PLC and selecting “Rename” facilitates 
renaming the device.
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The device settings now have to be set up to fit the PLC configuration. Following the steps shown in Figure 27:

1. Select the device representing the PLC.

2. Change the IP address to the CP 343 Lean IP address, in this example 192.168.200.20.

3. Select the Type as S7 300 CPU. The driver should behave as if it communicates with a CPU directly since the 
CP 343 Lean is transparent.

4. Enter the CPU rack number (NOT CP343), in this example 0.

5. Enter the CPU slot position on the rack (NOT CP343), in this example 2.

Figure 27.  
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The communications settings are now complete. Close the “Communications” module and enter the “Data Tags” 
module to map variables to PLC registers as shown in Figure 28. For example, to map a Data Block, do the follow-
ing steps:

1. Create an integer variable.

2. Select the variable, click on “Internal” in the Data tab and select the device (here S7 300).

3. Select the Siemens data item to exchange, here DB.

4. Choose the data type (refer to following note on Data Type).

5. Select the starting element for the data item (Identical to PLC addresses) and click OK.

Once the tags are inserted on the screen, the database is now ready and can be downloaded to the G3 HMI. 

Figure 28.  

Note On Data Type:

Byte as Byte means the variable will contain a Byte, Byte as Word means the variable will contain 
an integer word, and Byte as Long means the variable will contain an integer long; the G3 HMI 
asks the PLC the number of bytes required to reconstruct the data type selected. 

For example, for a Byte as Word mapped at DB001:006, the G3 will ask for DB001:006 and 
DB001:007 and reverse the bytes to reconstruct the word automatically. The address given in the 
Element should be the same as the one defined in the PLC Data Block for this example.
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Disclaimer

It is the customer's responsibility to review the advice provided herein and its applicability to the system. Red Lion 
makes no representation about specific knowledge of the customer's system or the specific performance of the 
system. Red Lion is not responsible for any damage to equipment or connected systems. The use of this document 
is at your own risk. Red Lion standard product warranty applies. 

Red Lion Technical Support

If you have any questions or trouble contact Red Lion Technical Support by emailing support@redlion.net or calling 
1-877-432-9908.

For more information: http://www.redlion.net/support/policies-statements/warranty-statement 
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