
       
 

 
 

TECHNICAL NOTE   TNOI32 
 

Title: G3 to MC Modbus Communication 
 

Product(s): G3 and Modular Controller V2 (CSMSTRV2) 
 

ABSTRACT 
This document provides an introduction to connect a G3 HMI to a Modular Controller CSMSTRV2 using 
Modbus Serial Communication. This setup can be duplicated between a G3 and a Modular Controller 
Enhanced Master (CSMSTRSX or CSMSTRGT) or Data Station Plus (DSPSX or DSPGT), although using 
OPC communication would be a better option in these cases since set up is easier. A technical note regarding 
the OPC set up can be found on Red Lion website here: 

http://www.redlion.net/Support/TechNotes/HumanMachineInterface/TNOI28.pdf 

The following description will not go through the Modular Controller modules set up and will assume 
knowledge of each modules parameters from the user. Please refer to the Modular Controller manual for 
module setup and parameter purpose. 

INTRODUCTION 
Modbus protocol is widely used in the industry and has become a standard for device-to-device 
communication. Many PLC programmers or users know the basics of this protocol and its flexibility and ease 
of use makes it the perfect communication tool to exchange data between Red Lion Products. This also 
provides compatibility with other products supporting Modbus that could eventually be attached to the same 
bus. Modbus is a single master multiple slave protocol. The G3 will be the master in this example. 

Multiple transport is supported by Modbus: RS232, RS485 or TCP/IP. The latest has it’s own protocol called 
Modbus TCP/IP. The following set up can be duplicated on any transports mentioned above with the only 
difference being the driver between serial and TCP/IP. Crimson 2.0 will only provide the drivers related to the 
transport during setup, thus avoiding errors. 

Fig. 1 shows the 3 different transports available and the drivers to be selected in each case. The following 
cables can be used for each communication: 

• RS232: CBLRLC01 or CBLRLC02 (1' or 10' length respectively) 

• RS485: CBLRLC05 

• TCP/IP: Standard Crossover Ethernet Cable for Point-to-Point or Straight Ethernet Cable if 
connected via a Switch. 

http://www.redlion.net/Support/TechNotes/HumanMachineInterface/TNOI28.pdf
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Fig. 1 

Both the G3 and Modular Controller are programmed using Red Lion Controls free software Crimson 2.0. 

MODULAR CONTROLLER SETUP 

Creating a Modular Controller Database 
The first step is to create a Modular Controller database. In Crimson 2.0, click on File>New and select 
Modular Controller for the Product Family and CSMSTRV2 for the Model. Fig. 2. 
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Enter in the area named Modules to insert the Modular Controller modules that fit the application. This step is 
required before the communication setup as data available for Modbus depends of the modules inserted. 

For this example, a CSPID2 and CSTC8 module are inserted. Fig. 3. 

 
Fig. 3 

Module can be programmed now or later. It will not influence data availability on the communication but only 
data formats when creating tags in the G3. For example, if the CSPID input is a thermocouple, the format will 
include one digit after the decimal point (000.0) where a process input might include two digits after the 
decimal point (000.00). 

NOTE: This format does NOT influence Modbus as the Modular Controller transfers whole numbers (integers) 
and the decimal point is just a “dummy” point inserted on the display. I.E. For a temperature of 35.6 F, the 
register value will be 356. 

Communication Settings 
Once the modules are set up, double-click the Master to close this section and open the Communications area. 
This example will use RS232 as a transport but it can be duplicated on any transports as long as the cable used 
and the driver associated are correct as shown in Fig. 1. 

The Modular Controller has to be set up as a Modbus Slave since the G3 will be the master. 

Select the RS232 Port and click the Edit button under the Driver Selection. This will open the driver picker 
popup window. Select Modbus under manufacturer and RTU Slave under Driver. Fig. 4. Click OK. 

A device called PLC1 now appears under the communication Port. This device represents the Modbus Master 
device, in our case, the G3. The device can be renamed for simpler usage. In this example, the name is changed 
to G3. Fig. 5. 



On the RS232 communication port, the Drop Number is the Modular Controller address on Modbus. If the 
application involves multiple Modular Controllers on the same bus, a unique address has to be used for each 
device. In this example, the address and port settings stay with default values. 

 
Fig. 4 

 
Fig. 5 



Port settings can be adjusted to achieve faster communication (higher Baud Rate). If these settings are 
changed, they will have to match the G3 settings set up later. 

Creating Data Blocks 
In order to exchange data with the Modbus master, the Modular Controller has to make data available in 
Modbus register addresses. This is done using Crimson 2.0 Data Blocks. 

Blocks are given a direction, MC to Device (Reading) or Device to MC (Writing). The Modbus master can 
only read from a Reading block but can read and write from a Writing block. For example, temperature 
readings should be linked to a reading block. On the other hand, setpoints or other adjustable data are linked to 
a writing block. 

NOTE: In build 287 or earlier, the term MC in direction did not exist and was replaced by G3. This G3 still 
referred to the device programmed, in this example, the Modular Controller. 

Making a Reading Block 

Select the device named G3 under the RS232 communication port and click on the Add Gateway Block button. A 
new block named Block1 is created. Select the block and click the Edit button next to the Start address. Fig. 6. 

In this example we will use Holding Registers to exchange data. Select Holding register and enter Element 1. 

 
Fig. 6 

Click OK and now the Edit button is available next to the Block Size. Click that button and enter the block 
dimension in number of registers. Here, we use 5. Fig. 7. Click OK. 



 
Fig. 7 

All the registers for the block now appear under Block1. From Start Address to Start Address + Block Size –1. 
Each register can now be linked to a Modular Controller module parameter. The direction is left as default. 

Select the first register (400001). The right hand side pane now displays available modules. Extend the 
Backplane and select Module1>Loop1>Status>PV (Loop1 Input process value). Fig. 8. 

 
Fig. 8 

Drag and drop the PV to register 400001. This Modbus register is now linked to this specific parameter. A 
small arrow in the center shows the direction data is transferred, i.e. MC to Modbus, so the master can only 
read this block. The block can be completed with more data from over modules as shown in Fig. 9. 

 
Fig. 9 



Making a Writing Block 

Select the device named G3 under the RS232 communication port and click on the Add Gateway Block button. 
A new block named Block2 is created. Select the block and click the Edit button next to the Start address. 

In this example we will use Holding Registers to exchange data as we did for the Reading block. Select 
Holding register and enter Element 101. Fig. 10. 

 
Fig. 10 

Click OK and now the Edit button is available next to the Block Size. Click that button and enter the block 
dimension in number of registers. Here, we use 2. Fig. 11. Click OK. 

 
Fig. 11 

All the registers for the block now appear under Block2. From Start Address to Start Address + Block Size –1. 

Click the Edit button next to the direction and change it to Device to MC. Fig. 12. Click OK twice. The block 
turns red. 

Each register can now be linked to a Modular Controller module parameter. Select the first register (400101). 
The right hand side pane now displays available modules. Extend the Backplane and select 
Module1>Loop1>Control>ReqSP (Loop1 setpoint). Fig. 13. 
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Drag and drop the ReqSP to register 400101. This Modbus register is now linked to this specific parameter. A 
small arrow in the center shows the direction data is transferred, i.e. both ways, so the master can read and 
write data in this block. The block can be completed with more data from over modules as shown in Fig. 14. 

 
Fig. 14 

 

The Modular Controller set up is now complete. Save and download the database in the device. 



G3 SETUP 
To create a new G3 database, in Crimson 2.0, click on File>New and select G3 Series for the Product 
Family and the corresponding G3 model for your application. This example will use a G310 but the setup is 
similar on all G3s. 

Communication Settings 
The first step is to program the communication settings to match the Modular Controller. 

Enter the Communications module and select the RS232 communication port. Click the Edit button under the 
Driver Selection. This will open the driver picker popup window. Select Modbus under manufacturer and 
Universal Master under Driver. Fig. 15. Click OK. 

 
Fig. 15 

The RS232 communication port now displays the driver and port settings. These have to be adjusted to match 
the Modular Controller. In this example, default settings are correct. 

A device called PLC1 appeared under the communication Port. This device represents the Modbus Slave 
device, in our case, the Modular Controller. The device can be renamed for simpler usage. In this example, the 
name is changed to MC. Fig. 16. 

When this device is selected, the right hand pane shows the different device settings available such as drop 
number and protocol options. These will only affect the selected device. Default setting fits this example. 

Communication setup is now complete. Data Tags can be created to access the MC values. 



 
Fig. 16 

Creating Data Tags 
Close the Communications module and enter the Data Tags module. We will first create a variable to read the 
temperature for Loop1 in the Modular Controller. 

Reading variable 

Click on the Integer Button under Create New Variable. A new variable named Var1 appears on the left pane. 
Rename the variable to TempLoop1. Fig. 17. 

When the variable is selected, the right hand pane displays the variable settings in multiple tabs. The variable 
now has to be linked to the Modular Controller. 

In the General tab, click the Internal button next to mapping and select MC. A popup window appears and 
shows the available registers for Modbus RTU master. This variable has to be linked to the 
Module1.Loop1.PV. In the Modular Controller database set up earlier, the Modbus address linked to this 
parameter is 400001. 

Select Holding Registers under Data item and enter element 1. Click OK. Fig. 18. 

This variable is now mapped to Modbus register 400001 in the device MC. The cross symbol next to the 
variable is now red. This informs the user that the variable is mapped to a device and can be read or written by 
the G3. However, since this variable is in a read block in the Modular Controller, its access has to be changed 
to Read Only. 

The access is available under the mapping. Once changed, a read only access is displayed as a green symbol 
next to the variable. 



 
Fig. 17 

 
Fig. 18 

NOTE: Putting a variable in read only provides Crimson a mean to check and inform the user if the database 
tries to write in the mapped area, thus avoiding errors for data that shouldn’t be written. 



Writing variable 

This is similar to the Reading variable setup. Click on the Integer Button under Create New Variable. A new 
variable named Var1 appears on the left pane. Rename the variable to StpLoop1. 

Select the variable and in the General tab, click the Internal button next to mapping and select MC. This 
variable has to be linked to the Module1.Loop1.ReqSP. In the Modular Controller database set up earlier, the 
Modbus address linked to this parameter is 400101. 

In the popup window, select Holding Registers under Data item and enter element 101. Click OK. 

This variable is now mapped to Modbus register 400101 in the device MC. The cross symbol next to the 
variable is now red. This informs the user that the variable is mapped to a device and can be read or written by 
the G3. 

Since this variable represents the Setpoint and can be changed from the HMI, the access is left to Read and Write. 

Fig. 19 shows a set of variable mapped in reference to the Modular Controller setup. 

 
Fig. 19 

In the format tab, the format for each variable can be adjusted. In this example, the number of digits after the 
decimal point should be set to 1. Please refer to the Modular Controller manual to identify the format required 
for the variable. 

Data Tags setup is now complete. 



Displaying information on the screen 
Close the Data Tags module and enter the User Interface module. 

Click on the screen to display the drawing box. Click on Insert>Tag or on the tag icon in the drawing box to 
open the Select Tag dialog box. Select the first tag (TempLoop1) and click OK. Fig. 20. 

Click and drag on the screen to insert the tag. 

 
Fig. 20 

Insert each tag on the screen in the same manner. Fig. 21. 

To make the setpoint tags changeable by the user, double click on the setpoint tag on the screen to display the 
properties and change Data Entry to Yes. Fig. 22. 
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Fig. 22 

The G3 is now ready to read and write data from the Modular Controller. Save the database and download it 
into the unit. Connect the cable and communication should start. 

Communication Summary 
The following figure shows the data exchange taking place between the G3 and the MC via Modbus RTU. 
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